Jumat, 28 Maret 2014

UBUNTU 12.04 gagal shutdown

periksa di system bios anda, pada power management pastikan feature ACPI anda sudah enable

edit /etc/default/grub



# nano /etc/default/grub
Cari baris ini :


GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Edit menjadi berikut dan simpan file tersebut.


GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"

Update grub dengan perintah ini:


# update-grub

reboot!   . kemudian coba tekan tombol power pada cpu anda... kal gagal, cari lagi................. :D

optimalkan squid

Set default FD jadi 1024
cheek di console default FD yang ada berapa nilainya dengan perintah:
# ulimit -n
1024

cara merubah angka 1024 ke 65536 dengan perintah:
# ulimit -HSn 65536
# echo "root soft nofile 65536" >> /etc/security/limits.conf
# echo "root hard nofile 65536" >> /etc/security/limits.conf

Selanjutnya 1 Tambahkan script
session required pam_limits.so
pada
# nano /etc/pam.d/common-session

Selanjutnya 2 Lakukan perintah :
# modprobe ip_conntrack
Dan tambahkan script
ip_contrack
pada file /etc/modules dengan perintah :
# nano /etc/modules
Lalu sisipkan code dibawah ini didalamnya
ip_conntrack

Kemudian ubah /etc/sysctl.conf dengan code berikut dengan perintah
# nano /etc/sysctl.conf
ubah atau ganti dengan dengan :
------------------------------
# Start Conf
# sysclt.conf
# Locate /etc/sysctl.conf
# For binary values, 0 is disabled, 1 is enabled. See sysctl(8) and
# sysctl.conf(5) for more details.
# max openfiles
fs.file-max = 65536
# Minimalis use swap disk
vm.drop_caches = 3
vm.swappiness = 3
# kernel.shmall = 2097152
# kernel.shmmax = 2147483648
# kernel.shmmni = 4096
# kernel.sem = 250 32000 100 128
net.ipv4.ip_local_port_range = 1024 65000
net.core.rmem_default = 262144
net.core.rmem_max = 262144
net.core.wmem_default = 262144
net.core.wmem_max = 262144
net.ipv4.tcp_low_latency = 1
net.core.netdev_max_backlog = 4000
net.ipv4.tcp_max_syn_backlog = 16384
net.ipv4.tcp_syncookies = 1
net.ipv4.tcp_timestamps = 1
net.ipv4.tcp_window_scaling = 1
net.ipv4.tcp_sack = 1
net.ipv4.tcp_timestamps = 1
net.ipv4.tcp_sack = 1
net.ipv4.tcp_mem = 786432 1048576 1572864
net.ipv4.tcp_rmem = 4096 87380 4194304
net.ipv4.tcp_wmem = 4096 65536 4194304
# net.ipv4.tcp_rmem = 4096 87380 8388608
# net.ipv4.tcp_wmem = 4096 65536 8388608
net.core.wmem_max = 8388608
net.core.rmem_max = 8388608
net.ipv4.tcp_tw_recycle = 1
# Controls IP packet forwarding
net.ipv4.ip_forward = 1
# Controls source route verification
net.ipv4.conf.default.rp_filter = 1
# Do not accept source routing
net.ipv4.conf.default.accept_source_route = 0
# Controls the System Request debugging functionality of the kernel
kernel.sysrq = 0
# Controls whether core dumps will append the PID to the core filename
# Useful for debugging multi-threaded applications
kernel.core_uses_pid = 1
# Controls the use of TCP syncookies
net.ipv4.tcp_syncookies = 1
# Controls the maximum size of a message, in bytes
kernel.msgmnb = 65536
# Controls the default maxmimum size of a mesage queue
kernel.msgmax = 65536
# Controls the maximum shared segment size, in bytes
kernel.shmmax = 68719476736
# Controls the maximum number of shared memory segments, in pages
kernel.shmall = 4294967296
# End Conf
-----------------------------------
Setelah itu check configurasi sysctl.conf lakukan dengan perintah:
# sysctl -p

Kemudian tambahkan entri berikut pada file /etc/security/limits.conf
# nano /etc/security/limits.conf (tambahakan script)
* - nofile 65536
root soft nofile 65536
root hard nofile 65536

Selesai & reboot

squid otomatis jalan

Setelah squid telah running dengan baik, maka untuk auto restart squid setelah di reboot, silahkan tuliskan script ini untuk auto start Squidnya:
# nano /etc/rc.local
ketik tepat pada bagian atas teks exit 0:
/usr/local/squid/sbin/squid -D

HTPROXY cara gampang membangun proxy squid...

source :

http://www.forummikrotik.com/guide/18550-%5Bshare-htproxy%5D-cara-mudah-install-proxy-videocache-pada-ubuntu-htproxy.html

https://code.google.com/p/squid-proxy-pkg/

http://www.hikmah-teknologi.com

Topologinya Squid sejajar client ( ip proxy satu subnet dgn client)

MODEM
|
MT
|
Swicth    ———-    Proxy Ubunt 12.04
|
Client

Client = 192.168.2.1-192.168.2.19
proxy = 192.168.2.20
Gateway = 192.168.2.30


/ip firewall nat
add action=dst-nat chain=dstnat comment="TRANSPARENT PROXY SEJAJAR" disabled=no dst-port=80 in-interface=Local protocol=tcp src-address=!192.168.2.20 to-addresses=192.168.2.20 to-ports=3128
add action=src-nat chain=srcnat disabled=no out-interface=Local protocol=tcp src-address-list=Local-Address to-addresses=192.168.2.1 to-ports=0-65535
/ip firewall address-list add address=192.168.2.2-192.168.2.19 list=Local-Address

Mesin proxy menggunakan biostar A740G M2L+ Ver. 6.x dengan prossesor X-3, OS Debian 6.06  , HD Seagate 250 G, Memory 6 Giga

ip 192.168.2.20
host = proxy domain = proxy.local.war.net
Memory = 1024 MB; HDD 120 Giga

partisi

/                                                                  18 G
/cache-1                                                  30 G
/cache-2                                                  30 G
/cache-3                                                  30 G
SWAP                                                        2 G

login pake non root user dgn putty dan enable kan root access


sudo passwd

login remote pake account root tambah repo webmin, dotdeb dan installasi build-essential supaya extract tar.bz2 tidak error

echo deb http://download.webmin.com/download/repository sarge contrib | tee -a /etc/apt/sources.list
cd /root
wget http://www.dotdeb.org/dotdeb.gpg
cat dotdeb.gpg | apt-key add -
wget http://www.webmin.com/jcameron-key.asc
apt-key add jcameron-key.asc
apt-get update && apt-get install build-essential

Install squid bila pake ubuntu 32 bit

cd /home
wget http://squid-proxy-pkg.googlecode.com/files/deb-htproxy_14942_i386.tar.bz2
tar xvf deb-htproxy_14942_i386.tar.bz2
dpkg -i *.deb
/etc/init.d/squid stop

Install squid bila pake ubuntu 64 bit


wget http://squid-proxy-pkg.googlecode.com/files/deb-htproxy_14942_x86-64.tar.bz2
tar xvf deb-htproxy_14942_x86-64.tar.bz2 && dpkg -i *.deb
dpkg -i *.deb
/etc/init.d/squid stop

kemudian bila selesei pake winscp edit file /etc/squid/squid.conf

sesuaikan dengan port, cache_mem, cache directory dan dns punyanya mas bro terus diubah kepemilikan folder cachenya
untuk 1 GB memory besaran cache_mem gak usah dirubah kayanya kalo partisi cache ama dnsnya bisa kaya gini

cache_dir aufs /cache-1 20000 20 256
cache_dir aufs /cache-2 20000 20 256
cache_dir aufs /cache-3 20000 20 256

#CONTOH DNS GOOGLE
dns_nameservers 203.130.208.18
dns_nameservers 203.130.193.74
dns_nameservers 203.130.196.5
dns_nameservers 222.124.204.34
dns_nameservers 203.130.196.6
dns_nameservers 208.67.222.222
dns_nameservers 208.67.220.220
dns_nameservers 180.131.144.144
dns_nameservers 180.131.145.145

Ubah kepemilikan directory cache

chown proxy:proxy /cache*

Optimalkan file system cache & ubah opsi untuk partisi cache

Disabled fsck (file system check)
nano /etc/fstab

Angka standart Drive Cache adalah 0 2 ——>> ganti dengan 0 0 (INGAT HANYA DRIVE CACHE)

Opsi Directory /cache :
Apabila menggunakan reiserfs gunakan opsi noatime,notail 0 0
Apabila menggunakan ext4 gunakan opsi noatime,barrier=0 0 0
Apabila menggunakan btrfs gunakan opsi noatime,compress,noacl 0 0

cek config bila ada yang error dan menjalankan squid pertama kali

squid -z
squid -f /etc/squid/squid.conf -z && /etc/init.d/squid start

edit sysctl.conf

nano /etc/sysctl.conf

fs.file-max=65536
vm.drop_caches = 3
vm.swappiness = 3
net.netfilter.nf_conntrack_acct= 1
net.ipv4.netfilter.ip_conntrack_max = 245000
net.ipv4.tcp_keepalive_time = 60
net.ipv4.tcp_keepalive_intvl = 10
net.ipv4.tcp_keepalive_probes = 6
net.ipv4.tcp_timestamps = 0
net.ipv4.tcp_sack = 0
net.ipv4.tcp_synack_retries = 2
net.ipv4.tcp_syn_retries = 2
net.ipv4.tcp_max_tw_buckets = 1440000
net.ipv4.ip_local_port_range = 16384 65535
net.core.rmem_max=16777216
net.core.wmem_max=16777216
net.ipv4.tcp_rmem=4096 87380 16777216
net.ipv4.tcp_wmem=4096 65536 16777216
net.ipv4.tcp_fin_timeout = 3
net.core.netdev_max_backlog = 30000
net.ipv4.tcp_no_metrics_save=1
net.core.somaxconn = 262144
net.ipv4.tcp_syncookies = 0
net.ipv4.tcp_max_orphans = 262144
net.ipv4.tcp_max_syn_backlog = 262144
net.ipv4.tcp_tw_reuse = 1
net.ipv4.tcp_tw_recycle = 1
net.ipv4.conf.default.rp_filter = 1
net.ipv4.conf.default.accept_source_route = 0
kernel.sysrq = 0
kernel.core_uses_pid = 1
kernel.msgmnb = 65536
kernel.msgmax = 65536
kernel.shmmax = 4294967295
kernel.shmall = 268435456
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1

setelah di save,

sysctl -p

edit squid.conf sesuai kondisi

chown proxy:proxy /cache-1 && chmod 777 /cache-1 && chown proxy:proxy /cache-2 && chmod 777 /cache-2 && chown proxy:proxy /cache-3 && chmod 777 /cache-3

squid -z

squid -f /etc/squid/squid.conf -z && /etc/init.d/squid start

iptables -F
iptables -X
iptables -t nat -F
iptables -t nat -X
iptables -t mangle -F
iptables -t mangle -X
iptables -P INPUT ACCEPT
iptables -P OUTPUT ACCEPT
iptables -A INPUT -s 192.168.2.0/24 -m state –-state NEW -p tcp –-dport 53 -j ACCEPT
iptables -A INPUT -s 192.168.2.0/24 -m state –-state NEW -p udp –-dport 53 -j ACCEPT
iptables -A INPUT -p tcp -s 192.168.2.0/24 -–dport 80 -j ACCEPT
iptables -A INPUT -p udp -s 192.168.2.0/24 -–dport 80 -j ACCEPT
iptables -A INPUT -p tcp -s 192.168.2.0/24 -–dport 8080 -j ACCEPT
iptables -A INPUT -p udp -s 192.168.2.0/24 -–dport 8080 -j ACCEPT

iptables -t nat -A PREROUTING -i eth0 -p tcp -–dport 8080 -j REDIRECT -–to-port 3128
iptables -t nat -A PREROUTING -i eth0 -p udp -–dport 8080 -j REDIRECT -–to-port 3128
iptables -t nat -A PREROUTING -i eth0 -p tcp -–dport 80 -j REDIRECT -–to-port 3128
iptables -t nat -A PREROUTING -i eth0 -p udp -–dport 80 -j REDIRECT -–to-port 3128
iptables-save -c > /etc/iptables.up.rules

perintah squid

squid -k parse
squid -k reconfigure
mengcek konfigurasi squid salah atau tidaknya

squid -z
membuat swap direktori

squid -DFY
ps -ax|grep squid

cek squid jalan atau tidaknya

perintah menjalankan dan menghentikan squid
sudo service squid start
sudo service squid restart
sudo service squid stop



perintah monitoring squid

squidclient -h localhost -p 8080 mgr:info
Sesuaikan port 8080 dengan port squid Anda.

tail -f /var/log/squid/access.log
Sesuaikan /var/log/squid/access.log dengan direktori log squid Anda.

squidclient -h localhost -p 8080 mgr:info | grep Hit
Sama seperti perintah pertama, sesuaikan -p 8080 dengan port squid Anda.

netstat plnat | grep squid
untuk mengetahui port squid kita

tail -f /var/log/squid/cache.log
Sesuaikan /var/log/squid/access.log dengan direktori log squid Anda.

tail -f /var/log/squid/access.log | grep HIT (log yang HIT saja)
Sesuaikan /var/log/squid/access.log dengan direktori log squid Anda.

Jumat, 21 Maret 2014

bootable hiren

dalam rangka install windows di komputer warnet yg banyak dengan tipe yang sejenis, dan untuk keperluan lain seperti memaksa format hardisk dkk, recover isi hardisk akhirnya saya memutuskan untuk membuat blog tentang membuat bootable flashdisk hiren 9.8, langsung aja gini langkah2nya..

alat dan bahan
file usb_format dan grub4dos disini
file hiren bot cd 9.8 disini yang terbaru juga bole tinggal search aja di google

membuat
insert flashdisk
format flashdisk dengan usb_format seperti gambar berikut







 hrn1


kemudian buka grub4dos ikuti gambar ini

hrn2

kalo keluar cmd seperti dibawah klik enter

hrn3

buka folder grub4dos copy kan ke flashdisk ente bro
hrn5

Dari folder Hiren’s.BootCD.15.2 copy folder “HBCD” dan “autorun.inf” ke flashdisk
hrn4

penampakan dalam flashdisk nih gan
hrn6

selanjutnya restart pc ente trus booting dengan flashdisk, silakan mencoba... kalo mo pake hiren versi yang lain silakan ganti folder HBCD ente dengan hiren yang baru... segitu saja gan